Ticket #715 (closed defect: wontfix)

Opened 8 years ago

Last modified 7 years ago

editor raises KeyError on start

Reported by: anonymous Owned by: FIFE
Priority: normal Milestone: Proposal
Component: demos/pychan_demo Version: trunk
Severity: normal Keywords:
Cc: Blocked By:
Blocking: Time planned:
Time remaining: Time spent:

Description

Traceback (most recent call last):

File "C:\Programme\FIFE\tools\editor\scripts\editor.py", line 104, in init

self._lighting_mode = int(TDS.get("FIFE", "Lighting"))

File "C:\Python27\lib\site-packages\fife\extensions\fife_settings.py", line 455, in get

if self._readSettingsCompleted[module] is not True:

KeyError?: 'FIFE'

Change History

comment:1 Changed 7 years ago by Aeromancer <alex@…>

This seems to be caused by the settings.xml file at ~/.fife

Perhaps scons should be modified to get rid of the file after building is completed?

comment:2 Changed 7 years ago by prock

  • Status changed from new to closed
  • Resolution set to wontfix

This is fixed by removing the old settings file and re-starting. Not in the books to fix this just yet although the settings module should be re-written at some point and should account for this.

Note: See TracTickets for help on using tickets.