Ticket #608 (closed defect: fixed)

Opened 3 years ago

Last modified 2 years ago

findChild() does not find hidden child widgets

Reported by: prock Owned by: FIFE
Priority: normal Milestone: 0.3.4
Component: engine/extensions/pychan Version: trunk
Severity: normal Keywords:
Cc: Blocked By:
Blocking: Time planned:
Time remaining: Time spent:

Description

2011-11-21T11:10:46  <totycro_> i've just found out that if you hide a widget, that's part of a parent, findChild() won't find it anymore, since it's now only part of hiddenChildren
2011-11-21T11:12:02  <totycro_> would it perhaps be possible to overload deepApply for containers, such that the hidden children also get considered?

Change History

comment:1 Changed 2 years ago by prock

  • Status changed from new to closed
  • Resolution set to fixed

(In [3841]) * Fixed deepApply() to now include hidden children in it's search. I have tested this minimally. closes #608

comment:2 Changed 2 years ago by prock

(In [3842]) * Fixed some small problems with my last commit. I had to add an option to the deepApply allowing you to only affect widgets that are visible.

  • The widget's visible state should also be accurate now. refs #608

comment:3 Changed 2 years ago by prock

(In [3843]) Still working on . Having some problems with the editor. Seems my changes have changed how the layout engine works. Still trying to find the cause. refs #608

comment:4 Changed 2 years ago by prock

(In [3844]) Found the cause of the odd behavior of the layout engine in the Editor (and UH noticed it as well). When removing items from an array you shouldn't be iterating through the array itself. This should finally put an end to this ticket . refs #608

Note: See TracTickets for help on using tickets.