Ticket #547 (closed defect: fixed)

Opened 4 years ago

Last modified 3 years ago

Cursor is sometimes displayed over letter in TextField

Reported by: totycro Owned by: FIFE
Priority: normal Milestone: 0.3.4
Component: engine/extensions/pychan Version: trunk
Severity: normal Keywords: guichan
Cc: Blocked By:
Blocking: Time planned:
Time remaining: Time spent:

Description

See screenshot: http://npshare.de/files/74e68601/guichan.png

The problem is located in textfield.cpp of guichan. The text is drawn with an offset of 3 (line 131), yet the caret isn't (line 126). Therefore there is some space before the text starts, but the caret doesn't "know" that.

This is fixable by removing the 3 or adding it to the caret. The first version creates strange problem for horizontal scrolling, the latter seems to work perfectly fine and fix the problem.

Change History

comment:1 Changed 3 years ago by prock

  • Component changed from utilities to engine/extensions/pychan
  • Milestone changed from Proposal to 0.3.4

Moving to 0.3.4

comment:2 Changed 3 years ago by totycro

  • Status changed from new to closed
  • Resolution set to fixed

(In [3833]) Fix caret position for TextFields? closes #547

Note: See TracTickets for help on using tickets.